Rechercher dans ce blog

jeudi 18 octobre 2007

OWA et IE 7 - Problème de compatibilité

Ayant récemment installé Windows Vista sur ma machine, en me rendant sur mon webmail Exchange 2003 j'ai remarqué un bug plutôt gênant.

 

En effet suite à la suppression du "Dynamic HTML Editiong ActiveX" d'IE il est impossible d'écrire des messages.

 

Microsoft met à votre disposition un patch corrigeant OWA que vous pouvez télécharger à l'adresse suivante :

http://www.microsoft.com/downloads/details.aspx?familyid=5bc06e8a-08eb-4976-bc68-a03ebe3a2552&displaylang=en

 

Attention, votre Exchange 2003 soit avoir le SP2 d'installer avant l'application de patch.

http://www.microsoft.com/downloads/thankyou.aspx?familyId=535bef85-3096-45f8-aa43-60f1f58b3c40&displayLang=fr

 

mercredi 12 septembre 2007

BOOT.INI

Boot INI Options Reference

Published: November 1, 2006

Introduction

There are number of BOOT.INI switches that are useful for driver developers that wish to test their drivers under a variety of different system configurations without having to have a separate machine for every one. For example, limiting the amount of memory NT sees can be useful for stressing memory loads, and limiting the number of processors for testing scalability. I've compiled a complete list of the options that BOOT.INI currently supports. This list is reproduced in the Startup, Shutdown and Crashes chapter of Windows Internals, where you'll find more information about the boot process. Entries in red were introduced in Windows 2000 and those in blue introduced in Windows XP or Windows Server 2003.

Note: to see what options a system has booted with examine HKLM\System\CurrentControlSet\Control\SystemStartOptions.

•

/3GB

•

Increases the size of the user process address space from 2 GB to 3 GB (and therefore reduces the size of system space from 2 GB to 1 GB). Giving virtual-memory- intensive applications such as database servers a larger address space can improve their performance. For an application to take advantage of this feature, however, two additional conditions must be met: the system must be running Windows XP, Windows Server 2003, Windows NT 4 Enterprise Edition, Windows 2000 Advanced Server or Datacenter Server and the application .exe must be flagged as a 3-GB-aware application. Applies to 32-bit systems only.

•

/BASEVIDEO

•

Causes Windows to use the standard VGA display driver for GUI-mode operations.

•

/BAUDRATE=

•

Enables kernel-mode debugging and specifies an override for the default baud rate (19200) at which a remote kernel debugger host will connect. Example: /BAUDRATE=115200.

•

/BOOTLOG

•

Causes Windows to write a log of the boot to the file %SystemRoot%\Ntbtlog.txt.

•

/BOOTLOGO

•

Use this switch to have Windows XP or Windows Server 2003 display an installable splash screen instead of the standard splash screen. First, create a 16-color (any 16 colors) 640x480 bitmap and save it in the Windows directory with the name Boot.bmp. Then add "/bootlogo /noguiboot" to the boot.ini selection.

•

/BREAK

•

Causes the hardware abstraction layer (HAL) to stop at a breakpoint at HAL initialization. The first thing the Windows kernel does when it initializes is to initialize the HAL, so this breakpoint is the earliest one possible. The HAL will wait indefinitely at the breakpoint until a kernel-debugger connection is made. If the switch is used without the /DEBUG switch, the system will Blue Screen with a STOP code of 0x00000078 (PHASE0_ EXCEPTION).

•

/BURNMEMORY=

•

Specifies an amount of memory Windows can't use (similar to the /MAXMEM switch). The value is specified in megabytes. Example: /BURNMEMORY=128 would indicate that Windows can't use 128 MB of the total physical memory on the machine.

•

/CHANNEL=

•

Used on conjunction with /DEBUGPORT=1394 to specify the IEEE 1394 channel through which kernel debugging communications will flow. This can be any number between 0 and 62 and defaults to 0 if not set.

•

/CLKLVL

•

Causes the standard x86 multiprocessor HAL (Halmps.dll) to configure itself for a level-sensitive system clock rather then an edge-triggered clock. Level-sensitive and edge-triggered are terms used to describe hardware interrupt types.

•

/CMDCONS

•

Passed when booting with into the Recovery Console (described later in this chapter).

•

/CRASHDEBUG

•

Causes the kernel debugger to be loaded when the system boots, but to remain inactive unless a crash occurs. This allows the serial port that the kernel debugger would use to be available for use by the system until the system crashes (vs. /DEBUG, which causes the kernel debugger to use the serial port for the life of the system session).

•

/DEBUG

•

Enables kernel-mode debugging.

•

/DEBUGPORT=

•

Enables kernel-mode debugging and specifies an override for the default serial (usually COM2 on systems with at least two serial ports) to which a remote kernel-debugger host is connected. Windows XP and Windows Server 2003 also support debugging through accept IEEE 1394 ports. Examples: /DEBUGPORT=COM2, /DEBUGPORT=1394.

•

/EXECUTE

•

This option disables no-execute protection. See the /NOEXECUTE switch for more information.

•

/FASTDETECT

•

Default boot option for Windows. Replaces the Windows NT 4 switch /NOSERIALMICE. The reason the qualifier exists (vs. just having NTDETECT perform this operation by default) is so that NTDETECT can support booting Windows NT 4. Windows Plug and Play device drivers perform detection of parallel and serial devices, but Windows NT 4 expects NTDETECT to perform the detection. Thus, specifying /FASTDETECT causes NTDETECT to skip parallel and serial device enumeration (actions that are not required when booting Windows), whereas omitting the switch causes NTDETECT to perform this enumeration (which is required for booting Windows NT 4).

•

/INTAFFINITY

•

Directs the standard x86 multiprocessor HAL (Halmps.dll) to set interrupt affinities such that only the highest numbered processor will receive interrupts. Without the switch, the HAL defaults to its normal behavior of letting all processors receive interrupts.

•

/KERNEL=/HAL=

•

Enable you to override Ntldr's default filename for the kernel image (Ntoskrnl.exe) and/or the HAL (Hal.dll). These options are useful for alternating between a checked kernel environment and a free (retail) kernel environment or even to manually select a different HAL. If you want to boot a checked environment that consists solely of the checked kernel and HAL, which is typically all that is needed to test drivers, follow these steps on a system installed with the free build:

•

Copy the checked versions of the kernel images from the checked build CD to your \Windows\System32 directory, giving the images different names than the default. For example, if you're on a uniprocessor, copy Ntoskrnl.exe to Ntoschk.exe and Ntkrnlpa.exe to Ntoschkpa.exe. If you're on a multiprocessor, copy Ntkrnlmp.exe to Ntoschk.exe and Ntkrpamp.exe to Ntoschkpa.exe. The kernel filename must be an 8.3-style short name.

•

Copy the checked version of the appropriate HAL needed for your system from \I386\Driver.cab on the checked build CD to your \Windows\System32 directory, naming it Halchk.dll. To determine which HAL to copy, open \Windows\Repair\Setup.log and search for Hal.dll; you'll find a line like \WINDOWS\system32\ hal.dll="halacpi.dll","1d8a1". The name immediately to the right of the equals sign is the name of the HAL you should copy. The HAL filename must be an 8.3-style short name.

•

Make a copy of the default line in the system's Boot.ini file.

•

In the string description of the boot selection, add something that indicates that the new selection will be for a checked build environment (for example, "Windows XP Professional Checked").

•

Add the following to the end of the new selection's line: /KERNEL=NTOSCHK.EXE /HAL= HALCHK.DLL

Now when the selection menu appears during the boot process you can select the new entry to boot a checked environment or select the entry you were using to boot the free build.

•

/LASTKNOWNGOOD

•

Causes the system to boot as if the LastKnownGood boot option was selected.

•

/MAXMEM=

•

Limits Windows to ignore (not use) physical memory beyond the amount indicated. The number is interpreted in megabytes. Example: /MAXMEM=32 would limit the system to using the first 32 MB of physical memory even if more were present.

•

/MAXPROCSPERCLUSTER=

•

For the standard x86 multiprocessor HAL (Halmps.dll), forces cluster-mode Advanced Programmable Interrupt Controller (APIC) addressing (not supported on systems with an 82489DX external APIC interrupt controller).

•

/MININT

•

This option is used by Windows PE (Preinstallation Environment) and causes the Configuration Manager to load the Registry SYSTEM hive as a volatile hive such that changes made to it in memory are not saved back to the hive image.

•

/NODEBUG

•

Prevents kernel-mode debugging from being initialized. Overrides the specification of any of the three debug-related switches, /DEBUG, /DEBUGPORT, and /BAUDRATE.

•

/NOEXECUTE

•

This option is only available on 32-bit versions of Windows when running on processors supporting no-execute protection. It enables no-execute protection (also known as Data Execution Protection - DEP), which results in the Memory Manager marking pages containing data as no-execute so that they cannot be executed as code. This can be useful for preventing malicious code from exploiting buffer overflow bugs with unexpected program input in order to execute arbitrary code. No-execute protection is always enabled on 64-bit versions of Windows on processors that support no-execute protection. There are several options you can specify with this switch:

•

/NOEXECUTE=OPTIN Enables DEP for core system images and those specified in the DEP configuration dialog.

•

/NOEXECUTE=OPTOUT Enables DEP for all images except those specified in the DEP configuration dialog.

•

/NOEXECUTE=ALWAYSON Enables DEP on all images.

•

/NOEXECUTE=ALWAYSOFF Disables DEP.

•

/NOGUIBOOT

•

Instructs Windows not to initialize the VGA video driver responsible for presenting bitmapped graphics during the boot process. The driver is used to display boot progress information, so disabling it will disable the ability of Windows to show this information.

•

/NOLOWMEM

•

Requires that the /PAE switch be present and that the system have more than 4 GB of physical memory. If these conditions are met, the PAE-enabled version of the Windows kernel, Ntkrnlpa.exe, won't use the first 4 GB of physical memory. Instead, it will load all applications and device drivers, and allocate all memory pools, from above that boundary. This switch is useful only to test device driver compatibility with large memory systems.

•

/NOPAE

•

Forces Ntldr to load the non-Physical Address Extension (PAE) version of the Windows kernel, even if the system is detected as supporting x86 PAEs and has more than 4 GB of physical memory.

•

/NOSERIALMICE=[COMx | COMx,y,z...]

•

Obsolete Windows NT 4 qualifier-replaced by the absence of the /FASTDETECT switch. Disables serial mouse detection of the specified COM ports. This switch was used if you had a device other than a mouse attached to a serial port during the startup sequence. Using /NOSERIALMICE without specifying a COM port disables serial mouse detection on all COM ports. See Microsoft Knowledge Base article Q131976 for more information.

•

/NUMPROC=

•

Specifies the number of CPUs that can be used on a multiprocessor system. Example: /NUMPROC=2 on a four-way system will prevent Windows from using two of the four processors.

•

/ONECPU

•

Causes Windows to use only one CPU on a multiprocessor system.

•

/PAE

•

Causes Ntldr to load Ntkrnlpa.exe, which is the version of the x86 kernel that is able to take advantage of x86 PAEs. The PAE version of the kernel presents 64-bit physical addresses to device drivers, so this switch is helpful for testing device driver support for large memory systems.

•

/PCILOCK

•

Stops Windows from dynamically assigning IO/IRQ resources to PCI devices and leaves the devices configured by the BIOS. See Microsoft Knowledge Base article Q148501 for more information.

•

/RDPATH=

•

Specifies the path to a System Disk Image (SDI) file, which can be on the network, that the system will use to boot from. Often used in conjunction with the /RDIMAGEOFFSET= flag to indicate to NTLDR where in the file the system image starts.

•

/REDIRECT

•

Introduced with Windows XP. Used to cause Windows to enable Emergency Management Services (EMS) that reports boot information and accepts system management commands through a serial port. Specify serial port and baudrate used in conjunction with EMS with redirect= and redirectbaudrate= lines in the [boot loader] section of the Boot.ini file.

•

/SAFEBOOT:

•

Specifies options for a safe boot. You should never have to specify this option manually, since Ntldr specifies it for you when you use the F8 menu to perform a safe boot. (A safe boot is a boot in which Windows only loads drivers and services that are specified by name or group under the Minimal or Network registry keys under HKLM\SYSTEM\CurrentControlSet\Control\SafeBoot.) Following the colon in the option you must specify one of three additional switches: MINIMAL, NETWORK, or DSREPAIR. The MINIMAL and NETWORK flags correspond to safe boot with no network and safe boot with network support, respectively. The DSREPAIR (Directory Services Repair) switch causes Windows to boot into a mode in which it restores the Active Directory directory service from a backup medium you present. An additional option you can append is (ALTERNATESHELL), which tells Windows to use the program specified by the HKLM\SYSTEM\CurrentControlSet\ SafeBoot\AlternateShell value as the graphical shell rather than to use the default, which is Windows Explorer.

•

/SCSIORDINAL:

•

Directs Windows to the SCSI ID of the controller. (Adding a new SCSI device to a system with an on-board SCSI controller can cause the controller's SCSI ID to change.) See Microsoft Knowledge Base article Q103625 for more information.

•

/SDIBOOT=

•

Used in Windows XP Embedded systems to have Windows boot from a RAM disk image stored in the specified System Disk Image (SDI) file.

•

/SOS

•

Causes Windows to list the device drivers marked to load at boot time and then to display the system version number (including the build number), amount of physical memory, and number of processors.

•

/TIMERES=

•

Sets the resolution of the system timer on the standard x86 multiprocessor HAL (Halmps.dll). The argument is a number interpreted in hundreds of nanoseconds, but the rate is set to the closest resolution the HAL supports that isn't larger than the one requested. The HAL supports the following resolutions: Hundreds of nanoseconds Milliseconds (ms) 9766 0.98 19532 2.00 39063 3.90 78125 7.80 The default resolution is 7.8 ms. The system timer resolution affects the resolution of waitable timers. Example: /TIMERES=21000 would set the timer to a resolution of 2.0 ms.

•

/USERVA=

•

This switch is only supported on Windows XP and Windows Server 2003. Like the /3GB switch, this switch gives applications a larger address space. Specify the amount in MB between 2048 and 3072. This switch has the same application requirements as the /3GB switch and requires that the /3GB switch be present. Applies to 32-bit systems only.

•

/WIN95

•

Directs Ntldr to boot the Consumer Windows boot sector stored in Bootsect.w40. This switch is pertinent only on a triple-boot system that has MS-DOS, Consumer Windows, and Windows installed. See Microsoft Knowledge Base article Q157992 for more information.

•

/WIN95DOS

•

Directs Ntldr to boot the MS-DOS boot sector stored in Bootsect.dos. This switch is pertinent only on a triple-boot system that has MS-DOS, Consumer Windows, and Windows installed. See Microsoft Knowledge Base article Q157992 for more information.

•

/YEAR=

•

Instructs the Windows core time function to ignore the year that the computer's real-time clock reports and instead use the one indicated. Thus, the year used in the switch affects every piece of software on the system, including the Windows kernel. Example: /YEAR=2001. (This switch was created to assist in Y2K testing.)

Thanks to Jonas Fischer for pointing out the PCILOCK and NOSERIALMICE switches. Thanks to Rob Green for information on the FASTDETECT switch.

mercredi 29 août 2007

ROOTKIT du MOMENT "Spyware-Secure" E.T.C... (29/08/2007)

SPYBOT et SPYWARE DOCTOR ne peuvent rien contre les Rootkits du moment .

Utiliser ce fichier gratuit qui est efficace, pour l'instant.


Qu'est ce qu'un Rootkit
Ensemble de logiciels, de mécanismes et de techniques permettant à un individu malveillant ayant accès à un ordinateur d'en devenir administrateur (utilisateur spécifique possédant les droits les plus étendus et susceptible d'accomplir les actions les plus diverses) et de s'y maintenir en dissimulant son activité aux yeux du système. Par extension, programme malicieux ou non capable de dissimuler son existence et son activité aux utilisateurs et aux moyens de détection classiques (antivirus, antispywares), sans pour autant permettre la prise de contrôle de l'ordinateur. Il existe désormais des
logiciels antirootkits pour rechercher et éliminer les rootkits.

dimanche 19 août 2007

Vista - Accès impossible à certaines pages, problème d'émails

Sous Vista, la couche TCP/IP s'optimise automatiquement. Dans certains cas de figure, cette fonction est incompatible avec certains modems/routeurs et il convient alors de la désactiver.
Cliquez sur Démarrer, Exécuter, tapez cmd et ensuite tapez :

netsh int tcp set global autotuninglevel=disabled

Si vous avez besoin de la réactiver, tapez :
netsh int tcp set global autotuninglevel=enabled

 

samedi 18 août 2007

XP - Réinitialiser le protocole TCP/IP

L'utilitaire NetShell vous permet de restaurer en cas de problème, l'état de la pile TCP/IP qui existait lors de l'installation du système d'exploitation.
Ouvrez une fenêtre de commande DOS et entrez la commande suivante :
netsh int ip reset c:\resetlog.txt
Cela aura pour effet de remettre le protocole TCP/IP dans le même état qu'après une installation de windows...

 

samedi 14 juillet 2007

SPEEDTOUCH - Reset Configuration

Pour réinitialiser le Speedtouch avec ses valeurs par défaut (@10.0.0.138 sans mot de passe d'accès) il faut suivre la procédure suivante :

1/ Assurez-vous que le SpeedTouch est hors tension.
2/ Appuyez une fois (brièvement) sur le bouton.
3/ Dès que le voyant Alimentation/Système se met à clignoter (en vert), appuyez une nouvelle fois sur le bouton d'alimentation.
4/ Le voyant Alimentation/Système cesse de clignoter et passe au vert fixe.
5/ Après six secondes, il recommence à clignoter. Appuyez de nouveau une fois (brièvement) sur le bouton.
6/ Tous les voyants clignotent une seule fois (en vert).
Les paramètres par défaut du SpeedTouch sont rétablis.

Petit Rappel :
Par défaut, le modem est à l'adresse 10.0.0.138. Pour le configurer, il faut donc relier son interface ethernet au réseau local, par exemple avec un câble entre la carte réseau de l'ordinateur et la prise RJ45 du modem, et s'assurer que la carte réseau de l'ordinateur est configurée correctement, le protocole TCP-IP installé dans une classe d'adresse compatible avec l'adresse par défaut du modem (exemple 10.0.0.1, masque 255.255.255.0).

vendredi 13 juillet 2007

SPEEDTOUCH - Installation et Configuration

Configuration du SpeedTouch 510 v4/v5/v6 facile V5.0
Le ST510v4 est livré dans sa version 4.2.3.0 du microcode (firmware) avec un programme intégré de configuration appelé Easy Setup, ainsi que 3 profils standards : PPPoA, PPPoE et Bridge, qui sont disponibles pour la quasi totalité des configurations (hors Free dégroupé).
Pour tous les fournisseurs d'accès hors Free, il est recommandé d'utiliser le profil PPPoA, mais PPPoE fonctionnera aussi. Ces 2 profils configureront votre ST510v4 en mode routeur, c'est à
dire que le NAPT est activé. Le serveur DHCP est en mode auto et le parefeu (firewall) activé.
Le profil "Bridge", c'est à dire "Ponté" désactive le routeur. On peut utiliser le mode "Bridge" pour utiliser le ST510v4 comme un simple modem, mais il est possible d'activer aussi dans ce mode le serveur DHCP pour le réseau local avec le programme de configuration.
Le ST510v5 à les même fonctionalité mais le menu d'accès est 'caché'. Le ST510v6 livré par Wanadoo semble bridé d'origine sur les fonctions routeurs. Il faut a priori changer le fireware.
Un site interressant :
http://bsk099.free.fr/ST510v6.

Interface web du routeur
Sur l'image ci-dessous, on peut voir l'écran de l'interface web qui permet d'accéder à Easy Setup.


Rappel :
Par défaut, le modem est à l'adresse 10.0.0.138. Pour le configurer, il faut donc relier son interface ethernet au réseau local, par exemple avec un câble entre la carte réseau de l'ordinateur et la prise RJ45 du modem, et s'assurer que la carte réseau de l'ordinateur est configurée correctement, le protocole TCP-IP installé dans une classe d'adresse compatible avec l'adresse par défaut du modem (exemple 10.0.0.1, masque 255.255.255.0).

Il suffit donc de lancer son navigateur à l'adresse http://10.0.0.138 pour le 510v4, ou http://10.0.0.138/ewizard.htm pour le 510v5, pour que cet écran s'affiche (si le ST510v4 demande un mot de passe ou que l'écran ne s'affiche pas, effectuez la procédure de réinitialisation*). Il faut ensuite dérouler le menu "Advanced" (1), le choix " Templates" (2) montre quels sont les profils disponibles, et pour lancer le programme de configuration, il suffit de cliquer sur Easy Setup (3).

Easy Setup
Ecran d'accueil : Sur cet écran, pas grand chose à dire, il faut cliquer sur Next.


Choix du profil :
Cet écran permet de sélectionner le profil désiré dans la fenêtre supérieure, après cette sélection on clique sur next



Choix des canaux ATM
Le programme demande de choisir le couple VPI/VCI, ce sera dans la quasi totalité des cas 8.35 (sauf Free dégroupé 8.36).




Sur l'écran ci-contre, on peut voir qu'il s'agit du profil PPPoA, le plus couramment utilisé. Avec le profil "Bridge" et le profil "PPPoE", une option supplémentaire est disponible sous forme d'une case cochée par défaut: "autoconfigured" (ne pas modifier). Cliquez sur next pour passer à l'écran suivant.



Pour le profil PPPoA :
Cet écran n'est demandé que pour le profil PPPoA, il suffit de
renseigner le nom d'utilisateur (user name) et le mot de passe
(password) pour se connecter chez votre FAI.



Cliquez sur next pour passer à l'écran suivant



Pour tous les profils :
Vous avez la possibilité, recommandé, de protéger l'accès ultérieur à
votre Speedtouch par un nom d'utilisateur (user name) et un mot de
passe (password) qu'il faut confirmer.


Cliquez sur next pour passer à l'écran suivant.

Pour tous les profils :
Voici le dernier écran, il affiche un rappel des choix. En cliquant
sur "Start", votre Speedtouch est configuré automatiquement, il se
réinitialise et se connecte tout seul (sauf en mode "Bridge").


En mode routeur, vous aurez la possibilité également de configurer des
règles NAPT avec l'interface web, activer / désactiver le serveur DHCP
(automatique par défaut) activer / désactiver le serveur DNS (activé
par défaut) activer / désactiver l'UPnP (activé par défaut) ...


http://www.eldin.net/routeurs/speedtouch510/speedtouch510v4.html

vendredi 29 juin 2007

IE7 - RunOnce intempestif

Windows Registry Editor Version 5.00
[HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main]
"RunOnceHasShown"=dword:00000001
"RunOnceComplete"=dword:00000001


le cas échéant supprimer
HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main\First Home Page

mercredi 20 juin 2007

TELNET - Lire et poster le courrier

Ce document traite sommairement de la manière de lire son courrier sur un serveur POP3 et de poster sur un serveur SMTP. Accessoirement, l'on y trouvera la méthode pour enlever sans le charger un message comportant en pièce jointe la dernière version du kernel Linux (TM) envoyé par un courageux anonyme et pure méchanceté.

Références
Lire son courrier
Effacer un message encombrant
Poster un message
Peut-on lire et poster avec autre chose que telnet ?
Remerciements

Références

Le lecteur sera bien inspiré de commencer par lire la documentation AVANT de commencer à poster.
Les RFC sont disponibles aux endroits habituels (par exemple ftp://ftp.lip6.fr/pub/rfc/rfc) et les "drafts" (brouillons) des sus-dits RFC juste à côté (ftp://ftp.lip6.fr/pub/rfc/internet-drafts).

  • RFC1939 Post Office Protocol - Version 3. J. Myers & M. Rose. May 1996. (Format: TXT=47018 bytes) (Obsoletes RFC1725) (Updated by RFC1957, RFC2449) (Also STD0053) (Status: STANDARD) rfc1939.zip
  • RFC1957 Some Observations on Implementations of the Post Office Protocol (POP3). R. Nelson. June 1996. (Format: TXT=2325 bytes) (Updates RFC1939) (Status: INFORMATIONAL)
  • RFC2449 POP3 Extension Mechanism. R. Gellens, C. Newman, L. Lundblade. November 1998. (Format: TXT=36017 bytes) (Updates RFC1939) (Status: PROPOSED STANDARD)
  • RFC0821 Simple Mail Transfer Protocol. J. Postel. Aug-01-1982. (Format: TXT=124482 bytes) (Obsoletes RFC0788) (Also STD0010) (Status: STANDARD) rfc821.zip
  • RFC2505 Anti-Spam Recommendations for SMTP MTAs. G. Lindberg. February 1999. (Format: TXT=53597 bytes) (Also BCP0030) (Status: BEST CURRENT PRACTICE)

Lire son courrier

La connexion au serveur se fait sur le port 11O (POP3) :

telnet pop3.chez.mon.fai pop3
Trying 192.168.1.1...
Connected to pop3.chez.mon.fai.
Escape character is '^]'.
+OK pop3.chez.mon.fai POP3 Server (Version 1.006d) ready at <Sun Feb 27 10:13:32 2000>
user toto
+OK please send PASS command
pass R5fg6Yh9
+OK 2 messages ready for toto
stat
+OK 2 1558
list
+OK 2 messages; msg# and size (in octets) for undeleted messages:
1 780
2 778
.
list 2
2 778

Bon, là on vient de voir comment se connecter (USR et PASS), comment avoir le total des messages (STAT) et quelques détails (LIST avec ou sans le numéro du message).

Maintenant lisons le courrier :

RETR 1
+OK message 1 (780 octets):
Return-Path: <titi@chez.lui>
Received: from [blabla chemin suivi par le message]
From: titi@chez.lui <Gros Titi>
To: toto@chez.mon.fai
Subject: Bonjour
Date: : Thu, 17 Feb 2000 21:38:05 +0100
Message-ID: <123456789.abcdefgh@mail.chez.lui>
 
blabla
blabla
 
.

Et si le message est trop long ?
Demandons à n'afficher que les 5 premières lignes du message numéro 2 :

top 2 5
[les en-têtes + la ligne blanche + les 5 premières lignes qui suivent]

Si le message est long, faire top 5 puis top 25 puis top 45 etc.

Et l'on quitte proprement (les messages lus restent dans la boîte aux lettres) :

quit
+OK pop3.chez.mon.fai POP3 Server (Version 1.006d) shutdown.
Connection closed by foreign host.

Effacer un message encombrant

Avec votre client mail habituel, le temps de chargement du courrier est excessivement long. Vous avez donc décidé d'aller voir avec telnet (se connecter comme indiqué ci-dessus) :

+OK 4 messages ready for toto
stat
+OK 4 25536114
list
+OK 4 messages; msg# and size (in octets) for undeleted messages:
1 1821
2 1819
3 1125
4 25530249

On regarde le message 4 de plus près :

top 4 15
+OK message 4 (25530249 octets):
Return-Path: <anonyme@nowhere>
Received: from [blabla chemin (truqué) suivi par le message]
From: anonyme@nowhere <un ami>
To: toto@chez.mon.fai
Subject: gnac gnac
Date: : Thu, 17 Feb 2000 21:38:05 +0100
Message-ID: <666@hell.angels>
MIME-Version: 1.0
boundary="------------83029AF363701F0491305448"
Status: O
Content-Length: 25184118
Lines: 344997
 
This is a multi-part message in MIME format.
--------------83029AF363701F0491305448
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit
 
Un cadeau de la part d'un neuneu
--------------83029AF363701F0491305448
Content-Type: application/x-gzip;
name="linux-2.3.45.tar.gz"
Content-Transfer-Encoding: base64
Content-Disposition: inline;
filename="linux-2.3.45.tar.gz"
 
H4sIAJxzpzgCA+w8aXfixrLz1foVHYbE4FgCvE0Gx3ODAY+5w3YAz2RePEcWkjCKtV0tXrK8
3/6qehGSQDa57yRvOeFYW1d3dXVVdXV1dbdty40fa6/+1F+9flR/c3wMz/pB/eAEn/XGEf0W
.

Bon, à vue de nez, c'est un cadeau d'un admirateur.
Pour effacer la chose :

dele 4
+OK message 4 marked for deletion
list
+OK 4 messages; msg# and size (in octets) for undeleted messages:
1 1821
2 1819
3 1125
.

L'effacement du message se fait après que l'on a quitté le serveur POP3 de façon normale par la commande quit.
Si l'on change d'avis avant de quitter, la commande RSET est bienvenue :

REST
+OK 4 messages ready for toto
list 4
+OK 4 25530249
dele 4
+OK message 4 marked for deletion
quit

Vous pouvez signaler les abus dans le groupe Usenet prévu à cet effet fr.usenet.abus.d.
Vous trouverez dans ce même groupe des pointeurs vers les documentations.

Poster un message

La connexion au serveur se fait sur le port 25 (SMTP) :

telnet smtp.chez.mon.fai. smtp
Trying 192.168.1.1...
Connected to smtp.chez.mon.fai.
Escape character is '^]'.
220 smtp.chez.mon.fai ESMTP Sendmail 8.9.3/8.9.3; Sun, 27 Feb 2000 15:58:15 +0100

L'on remarque tout de suite le ESMPT avec un "E" comme étendu : le serveur accepte le 8-bits.
Disons-lui bonjour en lui indiquent que nous aussi nous parlons le 8-bits couramment en répondant ehlo (s'il nous dit simplement SMTP nous répondrons HELO) suivi de notre nom de domaine. Le serveur n'est pas trop regardant sur la distinction majuscules / minuscules tant que l'on n'est pas dans les en-têtes ou dans le corps du message.

ehlo chez.mon.fai
250-smtp.chez.mon.fai Hello toto@ppp136.chez.mon.fai [192.168.1.2], pleased to meet you
250-EXPN
250-VERB
250-8BITMIME
250-SIZE
250-DSN
250-ONEX
250-ETRN
250-XUSR
250 HELP

On commence par écrire l'enveloppe :

mail from: toto@chez.mon.fai
250 toto@chez.mon.fai... Sender ok
rcpt to: titi@chez.lui
titi@chez.lui... Recipient ok
data
354 Enter mail, end with "." on a line by itself

Notons au passage que vous pouvez poster a) chez votre fournisseur à destination de n'importe qui à partir de chez vous, ou b) parfois sur un serveur smtp quelconque à destination d'un des clients du dit serveur, mais pas c) sur n'importe quel serveur pour n'importe qui à partir de n'importe où (message du type 550 titi@hop.la... Relaying denied ; c'est bien fait, non mais, tous les serveurs ne sont pas mal configurés.)
Maintenant passons aux en-têtes - certains champs dont la date et le Message-ID seront rajoutés par le serveur SMTP - en faisant bien attention à la syntaxe (majuscule initiale, minuscule, pas d'espace avant ":" mais une espace après) puis au texte du message séparé par une ligne blanche. Tout ça se finit par une ligne ne comportant qu'un point ".", et l'on quite par la commande quit si l'on a fini.

From: toto@chez.mon.fai
To: titi@chez.lui
Subject: test (de veau)
 
blabla
blabla
.
250 WAA11355 Message accepted for delivery
quit
221 smtp.chez.mon.fai closing connection
Connection closed by foreign host.

Un certain nombre d'en-têtes sont classiquement reconnus par les logiciels de courrier, on aura par exemple :

Organization: bof
X-Mailer: Linux netkit-telnet 0.14

L'on évitera soigneusement de mettre des accents dans les en-têtes.

Finissons en disant que l'accès aux serveurs SMTP est encore moins sécurisé que celui aux serveurs POP3, il n'y a même pas de mot de passe...

Peut-on lire et écrire avec autre chose que telnet ?

Il semblerait que oui.
Éric Jacoboni, a publié un article intitulé Gérer son courrier avec Perl dans le numéro 8 de juillet/août 1999 de Linux Magazine France.
Mutt (http://www.mutt.org) semble un très bon choix en mode texte.

Remerciements

Nous remercions les auteurs de telnet, TCP/IP, Linux, BSD, Sendmail, Postfix, et de tous ces jolis logiciels et belles documentations, sans qui l'on ne passerait pas tant de temps à discuter de choses et d'autres plus ou moins utiles (mais ça ne fait pas de mal).

Dernière mise à jour le dimanche 27 février 2000

 

OUTLOOK - Configuration POP Gmail

Les informations fournies ci-dessous sont également disponibles sous la forme d'une démonstration animée : Service POP Gmail

  1. Activez le protocole POP dans votre compte Gmail.
  2. Ouvrez Outlook 2003.
  3. Dans le menu Outils, choisissez Comptes de messagerie.
  4. Sélectionnez Ajouter un nouveau compte de messagerie et cliquez sur Suivant.
  5. Cliquez sur la case d'option associée au type de serveur POP3 et cliquez sur Suivant.
  6. Complétez les champs nécessaires avec les informations suivantes :

Informations sur l'utilisateur
Votre nom : entrez votre nom tel qu'il doit apparaître dans le champ De : des messages sortants.
Adresse de messagerie : entrez votre adresse e-mail Gmail complète (nom d'utilisateur@gmail.com).

Informations sur le serveur
Serveur de courrier entrant (POP3) : pop.gmail.com
Serveur de courrier sortant (SMTP) : smtp.gmail.com

Informations de connexion
Nom d'utilisateur : entrez votre nom d'utilisateur Gmail (@gmail.com compris).
Mot de passe : entrez votre mot de passe Gmail.

  1. Cliquez sur Paramètres supplémentaires et accédez à l'onglet Serveur sortant.
  2. Cochez la case Mon serveur sortant (SMTP) requiert une authentification et sélectionnez Utiliser les mêmes paramètres que mon serveur de courrier entrant.
  3. Cliquez sur l'onglet Avancé et cochez la case Ce serveur nécessite une connexion cryptée (SSL) sous Serveur entrant (POP3).
  4. Cochez la case Ce serveur nécessite une connexion cryptée (SSL) sous Serveur sortant (SMTP) et entrez 465 dans le champ associé à cette option.
  5. Cliquez sur OK.
  6. Cliquez sur Tester les paramètres du compte... après l'affichage du message Félicitations ! Tous les tests se sont déroulés avec succès. Cliquez sur Fermer pour continuer.
  7. Cliquez sur Suivant, puis sur Terminer.

* Avez-vous cliqué sur Enregistrer les modifications après l'activation du protocole POP dans Gmail ? Pour permettre à Gmail de communiquer avec votre client de messagerie, n'oubliez pas de cliquer sur Enregistrer les modifications sur la page Paramètres de messagerie.